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ViewBuilder is the tool used as an adjunct to create graphics and drawings that i-Vu Open does not already 
have in its Library, or to change existing graphic views.   

Operators can use these graphics to monitor and control their building automation system.   

  

 
 

What is ViewBuilder? 
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TIPS  

• ViewBuilder has a right-click menu that includes keyboard shortcuts for most commands. 

• To show or hide the Tools , Control Properties , or System  windows, click the toolbar button 
that matches the window's icon.  

• To make the Tools, Control Properties, and System windows fade to transparent when not in use, select 
Configure > Preferences. 

• Hold down the space bar and the left mouse button, then move the graphic around in the workspace 
using the hand tool. 

• Press Home on the keyboard to align the top left corner of the graphic with the top left corner of the 
workspace. 

• Hold down F9 to hide all handles and lock icons. 
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To select objects 

You must select an object to perform any action on it. 

• To select a single object, click it. 

• To select multiple objects, hold down Shift while you click them.  
Or, click and drag a rectangle around the objects, then release the mouse button. 

• To select every object, right-click and choose Select All. 

• To clear all selections, right-click and choose Deselect All (Ctrl+Shift+A). 

  

 
 

To move objects 

To move a selected object(s): 

• Click and drag the object to the new location. Hold down Shift as you drag an object to constrain its 
movement to horizontal or vertical. 

• Use the arrow keys to nudge the selected object one pixel at a time, or hold down Shift while using the 
arrow keys to move the object ten pixels at a time. 

• Select Edit > Move to move an object to specific coordinates in the workspace. 

  

 
 

To align, group, or layer objects 

Select the object(s) you want to align, group, ungroup, or reorder (front to back), then use the right-click menu 

commands or the options on the Align Object tab  in the Tools window. 

NOTES 

• Objects align in relationship to the last selected item, the one with the green handles. 

• You can select an individual control in a group to edit its properties. 

  

 
 

To copy an object 

Click  to copy the selected object, then click  to paste the object in the existing view or a different view.  
Or, hold Alt while dragging an object to create a duplicate object. 
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To lock or unlock objects 

To lock a selected object(s) so you cannot select or move it, right-click the object, then select Lock. 

To unlock an object, Ctrl+right-click the object, then select Unlock. 

NOTES 

• To unlock a table, Ctrl+right-click on the small grid above the table. 

• To unlock all locked objects simultaneously, right-click anywhere in the workspace and select Unlock All.  

• Hold down the F9 key to hide the lock icons. 

  

 
 

To undo or redo actions 

Click  as many times as necessary to undo actions that you performed in the current session of 
ViewBuilder, beginning with the most recent action. Click   to redo the action. 

You can also click the drop-down arrow to the right of the Undo or Redo button to select an action from a list 
that begins with the most recent action. Selecting an action will undo or redo that action, plus all actions 
above it in the list. 

  

 
 



 
 
 

ViewBuilder 5.1 5 
 

You can use ViewBuilder to edit existing graphics (page 5) that were created in ViewBuilder, edit graphics 
from the i-Vu Open Library (page 5), or create new graphics (page 6).   

  

 
 

Editing a graphic 

To edit a graphic that was created in ViewBuilder, open the graphic file. 

 

To edit...  

An image See Editing an image in a graphic 8 (page ). 

A drawing Use the Alignment/Drawing tab in the Tools window. See To draw vector 
shapes and lines. 

A control 1 Select the control. 

2 Edit any properties in the Control Properties 

A link 

window. See Controls and 
their properties. 

1 Right-click the control that is a link. 

2 Select Link

3 Edit the fields in the dialog box as needed. See 

. 

Adding links 22 (page ) 
for a description of each field 

A table See Working with tables. 

  

 
 

To edit a graphic from i-Vu Open in ViewBuilder 

NOTE  Only the Installer role has access to the following. 

 

To edit a graphic from i-Vu Open in ViewBuilder: 

1 Select the piece of equipment in i-Vu Open navigation tree. 

2 Right click on the equipment name and select Configure. 

3 Click Edit button under Views. 

4 Click Save to desktop or other appropriate folder. 

5 Open ViewBuilder. 

6 Select File > Open.  Browse to your saved graphic and click to open. 

7 Edit as desired. 

8 Save with a new name - the original system name is locked and cannot be used for an edited graphic.  

NOTE  Names are case sensitive and should not have spaces and/or special characters. 

Working with graphics 
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To upload your graphic to i-Vu Open 

1 Login to i-Vu Open.  You must have Installer role to upload graphics. 

2 Select the area or equipment in the navigation tree. 

3 Right-click and select Configure. 

4 Click the Add button under Views. 

5 Browse to your .view graphic file that you created in ViewBuilder. 

6 Click Continue.  

7 Click Close when message appears File added successfully. 

8 Click Close again. The graphic should appear on your i-Vu Open screen. 

  

 
 

Creating a graphic 

A graphic can be created to display the status of multiple zones or equipment from a single view. The area or 
floorplan graphics can be set up with Equipment Color controls  to provide a visual representation of 
the comfort level in each zone.   

Values, text, and links can also be added to area and floorplan graphics.  Clicking on a link zooms in on an 
individual zone or individual piece of equipment for closer examination. 

To create a graphic: 

1 In a graphics program, prepare any custom images (page 7) such as floorplans. 

2 In ViewBuilder, click  to start a new graphic file, or File>New.  

3 Save the file as a .view in a folder you will remember or place on your desktop.  

NOTE  Save your work often. 

4 Add a beginning image (page 7), such as a duct or floorplan. 

5 Add images (page 7), controls (page 8), and symbols (page 23) as needed. Use the Equipment Color 
control  to display the temperature in a zone relative to the designated setpoints for that zone. 

NOTE  Graphic objects must stay within the gray lines that indicate the edges of your graphic. If this is not 
possible at the current graphic size, see To change the graphic size (page 7) below. 

6 Test your graphic in i-Vu Open. 

7 Transfer the .view file to the end user’s server.  

NOTE  To record notes or information about the graphic, select Configure > View Properties, then type your 
name and comments on the Summary tab. Revision History shows each time the graphic was saved and the 
workstation it was saved on. 

TIP  You can use ApplicationBuilder to generate a control program for the UC or CC. 
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To change the graphic size 

The default size of a new graphic is 741 x 543 pixels.  This size graphic fits in the i-Vu Open action pane when 
the navigation tree is displayed, the screen resolution is set at 1024 x 768, and Internet Explorer is 
maximized and in full-screen mode.  A graphic that is 976 x 569 pixels fits the action pane when the tree is 
hidden. 

To change the size of your graphic: 

1 Select Configure > View Properties. 

2 Under General, select the size you want or enter a custom size (in pixels). 

3 Click OK. 

NOTE  ViewBuilder shows the borders of your graphic with a thin gray line.  

  

 
 

To change a graphic’s background color 

1 Select Configure > View Background Color. 

2 Select the color you want. 

3 Click OK. 

  

 
 

Working with images 

You can add images, such as floorplans or site maps, to your graphic. Create your image in a graphics 
program and save it in a folder.  Create a floorplan image as a .gif or .png; create any other image as a .gif, 
.png, or .jpg. 

  

 

 
 

To add an image to your graphic 

1 Click the Add Image tab  in the Tools window. 

2 In the Look in field, browse to the folder that contains the image you want. 

TIP  Click one of the five buttons at the left of the file list to jump to a location quickly. Hold the cursor 
over a button to see its destination. 

3 Select the image. 

4 Click in the workspace to place the image. 

TIP  You can also double-click a file name in the Tools window to add the image to the workspace. 

5 Enter an image in the Mouseover Image field in the Control Properties window if you want i-Vu Open to 
display a different image when the cursor is over the image. 
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NOTES 

• The mouseover image must be the same size as the other image. 

• To add the image multiple times, select the image, then hold down Shift and click the workspace for 
each image. 

• You can set an image to show or hide in i-Vu Open based on the value of a microblock property. See 
Setting objects to show/hide (page 24). 

• You can make an image link to another page in i-Vu Open or to the Internet. See Adding links (page 22). 

  

 
 

To resize an image 

To resize an image, you can type the desired Width and Height (in pixels) in the Control Properties window or 
do the following: 

1 Select a single, ungrouped image. 

2 Click and drag one of the green handles. 

NOTE  Hold down the Shift key as you drag to maintain the image's proportions. 

  

 
 

Editing an image in a graphic 

1 Edit the original image (.gif, .png, or .jpg) in a graphics program. 

NOTE  If you do not have the original image, follow the procedure below in “To export an image”. 

2 If the image in your graphic has no functionality in ViewBuilder, such as linking, delete the image, then 
add the revised image. 

3 If the image has functionality in ViewBuilder that you want to retain, follow the procedure in To add an 
image (page 7). 

  

 
 

Working with controls 

You can add controls to a graphic that can retrieve and allow editing of data in the system’s equipment, for 
example, status values, the date and time, trend graphs, or setpoint graphs. 

NOTES 

• You can make some controls link to other pages in i-Vu Open or to the Internet. See Adding links (page 
22). 

• Hold down F8 to see an indicator beside all controls that need to have a microblock path defined in the 
Control Properties window. 
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To add a control 

1 Click the Add Control tab  in the Tools window. 

2 Select the control you want to add. See Controls and their properties for a description of each control. 

3 Click in the workspace where you want to add the control. 

NOTE  To cancel the action, press Esc before clicking the workspace. 

4 Edit properties for the control in the Control Properties window. See Controls and their properties. 

5 Click anywhere in the workspace to apply the properties. 
 

TIPS   

• To add a control multiple times, select the control, then hold down Shift and click the workspace for each 
copy. 

• Hold Alt while dragging a control to create a copy of it. 

  

 
 

Controls and their properties 

When you add a control to a graphic, you define properties in the Control Properties window to define what 
data the control will retrieve or how the control will behave in i-Vu Open. Most controls have the following 
three properties. 
  

The path to the microblock you want the control to read from or write to. See Microblock Path To determine a 
microblock path to points 25 (page ) to find out how to ascertain the path. 

NOTE  If this field is outlined in red, you entered invalid syntax or characters. 

The microblock property you want to read from or write to. Click the down arrow to select a 
common property (usually present_value) or type the property you want.  

Property 

Select to make the control editable in i-Vu Open. The microblock must have editable 
properties. 

Editable 

 
  
The following table lists all the controls you can add to a graphic and any other properties besides the three 
described above.  
  

Use this control... To... Properties 

 Display text that 
does not change.   
Example: A 
description of a 
control 

Static Text Text—The text you want the control to display in i-Vu Open. 
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Use this control... To... Properties 

 Display text from 
the character string 
field in a 
microblock.  
Example: Point 
name 

Single-line 
Text 

Preview Text

NOTE  To display the Notes defined in i-Vu Open for an area or 
piece of equipment, enter the path to the area or piece of 
equipment in the Microblock Path field, then type 
.notations in the Property field. 

—Text that is displayed only in ViewBuilder to help 
you place the control. Type the preview text or select from the 
drop-down list. 

 
Place a multi-line 
text box on a page. 
Example: Long text 
of an alarm 

Multi-line 
Text 

Wrap text—Wraps text from line to line inside the text area box. 

Provide Scrolling—Includes scrollbars. 

Visible Row Count—The number of rows the text area will display. 

Visible Column Count—The estimated number of characters a row 
will display. This estimate helps you avoid overlapping other 
page elements when positioning the control in ViewBuilder. 

 Display active and 
inactive text values 
for a binary 
microblock. When 
editable, can be 
toggled between 
multiple states by 
clicking on it. 
Example: Chiller is 
enabled or disabled 

Text Toggle Preview Text-Text that is displayed only in ViewBuilder to help 
you place the control. Type the preview text or select from the 
drop-down list. 

 
Display the text 
values for BACnet 
multi-state 
microblocks. A 
droplist can also 
display the active 
and inactive text 
values for a binary 
microblock. When 
editable, appears 
as a droplist with 
multiple options. 
Example: Units of 
measure (°F) 

Droplist 
 

Preview Text-Text that is displayed only in ViewBuilder to help 
you place the control. Type the preview text or select from the 
drop-down list. 

  
The fields on this tab provide a method of substituting the 
microblock property values with different text.  
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Use this control... To... Properties 

 Display two 
different images to 
represent the on 
and off states of a 
microblock 
property. 
Example: The 
control reads a fan 
status value, then 
displays a static 
image of a fan to 
indicate the fan is 
off and an 
animated image to 
indicate it is on. 

Toggle Button 
 

Images—To use images other than a checkbox, click  to 
locate the On and Off image files. 

 
If you want to display custom images for the following 

conditions, click  to locate the image. 

Mouseover Image—The image to be displayed when the cursor is 
over the button to indicate a clickable link. 

Pressed Images—The images to be displayed when the cursor is 
on the button and the mouse button is pressed down, but not 
yet released. 

Disabled Images—The images to be displayed when buttons are 
not editable. 

 Display any 
numerical value 
from an analog 
microblock.   
Example:  Zone 
temperature 

Number 
 

Max Right Digits—The maximum number of digits to be displayed 
to the right of the decimal. Type 0 to display whole numbers. 

Min Left Digits—The minimum number of digits to be displayed to 
the left of the decimal (usually 1).  

Expected Left Digits—The number of digits that might appear to 
the left of the decimal. These digits are only displayed in 
ViewBuilder to help you position the control. 

Create Units Control—Adds a Droplist control to the right of the 
Number control. The microblock must have a units field that 
identifies the number (for example, RPM). The Microblock Path is 
the same as the Number control. Type or select a Preview Text 
option. This text is only displayed in ViewBuilder to help you 
place the control.  

 
Scaling Factor—To display a microblock property value in a 
different format, type the necessary multiplication factor. For 
example, to display watts as kilowatts, type .001 in this field. 

Show plus sign—Displays a plus sign when the value is positive.  

NOTE  You can use the Number control to display the number of 
alarms pending a return-to-normal state for an area or 
equipment. To do this, enter the path to the area or equipment 
in the Microblock Path field, then type .alarm_count in the 
Property field. 
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Use this control... To... Properties 

 
Show various 
states of an analog 
microblock using 
images.  
Example: A closed 
damper is shown 
when the analog 
value is 0; a half-
open damper is 
shown when the 
value equals 50; 
and a fully open 
damper is shown 
when the analog 
values equals 100. 

Image List 
Default Image—Click  to locate the image you want the 
control to display when a communication problem or error 
occurs. Use a different image from the others in the image list 
so that the i-Vu Open operator will know when an error occurs. 
For example, some symbols that use image lists have default 

images with  in the center of the image. 

Click  to add the images the control displays under normal 

conditions. Use  and  to reorder the list. Click  to 
delete an image from the list.  

Expression—Enter an expression for each image (except the 
default image) to define the condition for displaying the image. 
See Conditional expressions 27 (page ). When the graphic is 
displayed in i-Vu Open, i-Vu Open evaluates each expression in 
the order of your list and displays the first image whose 
expression returns true. If no expression returns true, the 
default image is displayed. 

 
Display a horizontal 
or vertical slider bar 
that can be used to 
adjust an editable 
point. Example: 
Editing a setpoint 

Slider 
 

Display Orientation—Displays the slider horizontally or vertically.  

Minimum Value—The minimum value on the slider.  

Maximum Value—The maximum value on the slider. 

Tick Interval—The number of units from one tick to another.  
NOTE  To have the slider divisions appear correctly, the slider 
range (maximum value minus minimum value) should be evenly 
divisible by the tick interval.  

Slide By This Increment—The number of units the slider jumps 
when you move it. 
 
 

 

  
To use custom images for the slider, click  to locate the 
image files. 
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Use this control... To... Properties 

 Display a date,  
typically read from 
a History 
microblock.  
Example: Date of 
the highest zone 
temperature 

Date Show day of week—Adds the day to the right of the date. 
  

NOTE

• the equipment graphic, type

  To display a controller's current date on: 

 
~device/driver/device/local_date in the 
Microblock Path

• an area graphic, type

 field. 

 
<equipment_ref_name>/~device/driver/devic
e/local_date in the Microblock Path

In either case, delete the text in the 

 field. 

Property field. 

 
Display a time of 
day, typically read 
from a History or 
Wire Lock 
microblock. 
Example: Time of 
the day's highest 
temperature 

Time Display Format—Choose how to display time. 
  

NOTE

• the equipment graphic, type

  To display a control module's current time on: 

 
~device/driver/device/local_time in the 
Microblock Path

• an area graphic, type

 field. 

 
<equipment_ref_name>/~device/driver/devic
e/local_time in the Microblock Path

In either case, delete the text in the 

 field. 

Property field. 

 Display a time 
period. Example: 
Override time 
remaining 

Duration Select Show Hours and Show Seconds to display these with the 
minutes. 

NOTE  This control expects an analog value expressed in 
seconds. If you want i-Vu Open to display hours, the duration 
control must read a microblock property that furnishes data in 
seconds. 

 
Place a BACnet 
trend on a graphics 
page. Example: 
Trend graph of zone 
temperature 

Trend Graph Trend location—To add a point or wire trend graph, type the 
microblock path. To add a trend graph that shows multiple 
points, type the reference name of the graph. To find the 
reference name, navigate to the graph in i-Vu Open, then click 
the Configure tab. The reference name appears at the top of the 
page. 

Title Font Size—Adjust the size of the graph's title. 

Trend Font Size—Adjust the size of the graph's numbers. 
 

 
Serve as a 
backdrop for other 
objects. 

Panel Move the handles to adjust the shape of the panel. 

 
Align multiple 
controls in rows 
and columns.  
Example: Fan 
status table 

Table See Working with tables. 
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Use this control... To... Properties 

 
Add text, controls, 
or images to a 
resizable container 
that wraps the 
objects to fit the 
container. 

Flow Layout To add content to the Flow Layout control: 

• Double-click it to type text. 
NOTE

• Drag and drop other controls or images into it. 

  Press Esc to exit the control without saving the text. 

NOTE

Click and drag the Flow Layout's handles to resize it.  

  You cannot insert a Panel, Table, HTML, or another 
Flow Layout control. 
  

Use the options in the Control Properties

• Align the contents in the Flow Layout control 
 window to: 

• Wrap the text  
• Change the border's thickness 
• Change the border or background color 

 

 

 Provide a method 
to lock a piece of 
equipment on, lock 
it off, or let the 
control program 
control it (Auto).  
Example: To control 
fans or pumps 

On-Off-Auto Microblock Path—Type the path in this field only if this control is 
to read one microblock. 

Type: Select... 

 

To display... 

Dial 

 

 
Vertical Panel 

 

 
Horizontal Panel 

 
Order—Select the order of the control labels. The order is left to 
right for Dial and Horizontal Panel, or top to bottom for Vertical 
Panel. 

Use State Text—Enable this field to use the binary microblock's 
Active text and Inactive text instead of the control's defaults. 

Use Advanced Path—Enable this field if you want this control to 
read two microblocks, one for Auto and one for On/Off 
(Hand/Off). Enter the microblocks in the following fields. 

Automatic Microblock Path and Property—The microblock that 
contains the Auto values.  

Manual Microblock Path and Property—The microblock that 
contains the On/Off values. 
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Use this control... To... Properties 

 
A set of radio 
buttons provide a 
method to view or 
edit the various 
states of a 
microblock 
property.  
Example:  Manual 
and Auto 

Radio Button Enter the same Microblock path and Property for each radio 
button in the set. 

Radio Button Value

For an analog microblock, type the specific value the button is 
to represent. 

—If the button is not editable, type the value 
that will turn the button on. If the button is editable, type the 
value that the property will change to if an operator selects the 
button. 

For a binary microblock, type true or 1 (depending on the 
property) for one button's value and false or 0 

The remaining fields for this control are the same as those for 
the Toggle Button. 

for the 
other button's value. 

 Provide a method 
to view or edit 
setpoints. 

Setpoint Setpoint Type— 

Select... To display... 

Actual 

 
Occupied and unoccupied setpoints 
programmed into the setpoint microblock 

Effective 

 
Effects of factors such as overrides, 
adjustments, and hysteresis. 

 

 
Provide a method 
to adjust or 
override a 
temperature 
setpoint 

Interactive 
Thermostat 

Microblock Path— This control defaults to lstat, the default 
RefName

In a control program generated in i-Vu or ApplicationBuilder, the 

 for the RS microblock when you create your control 
program in Snap. 

RefName defaults to zone_temp

You can verify your 

.  

RefName in the RS microblock.    

 Place a BACnet 
object ID on a 
graphics page. 

BACnet  
Object ID 

Instance Number Only—Select to allow an operator to edit only the 
instance number of the BACnet object ID on a graphic. 

 
Add any HTML to 
the graphic.  
Example: To embed 
a flash movie. 

HTML Move the handles to adjust the shape of the HTML control. 

 
Preview Image—Click  to locate an image that will display 
only in ViewBuilder.  

Insert HTML—Enter any HTML and resource file references that 
are acceptable within the HTML <body> tag. Add any resource 
file on the Resources tab. In the HTML, type the file path as 
resources/<filename.extension>.  

  

Click  to add files to the Resources list. Click  to delete 
files from the list. 
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Use this control... To... Properties 

 To view the state of 
the Prime Variable 

Equipment 
color 

 In i-Vu Open, the oval will display colors to indicate the status 
of the equipment in relation to its prime variable (for example, 
ideal, warm, occupied, etc.). 

Equipment Path - 

1. Open i-Vu Open. 

To determine equipment path:  

2. Right-click on equipment in navigation tree and click  
Copy Path. 

3. Open ViewBuilder. 

4. Paste.  

Size - Choose the size of the oval that you wish to appear on 
your graphic. 

Show Prime Variable - Displays the prime variable. 

For more information, See To use an Equipment Color control
16

 
(page ). 

  

TIPS 

• The symbol library contains preconfigured, commonly used controls. See Working with symbols. 

• Several controls let you select images in the Control Properties window. You can quickly select an image 
that you previously added to your graphic by clicking the browse button, then clicking the Resources tab 
in the file selection dialog box. You do not need access to the original image because images are stored 
in your graphic. This does not apply to images from the _common folder. 

• To change the font, size, color, or style for any control that displays alphanumeric characters, click . In 
the Font Size field, you can select or type the size you want.  

NOTE  If you change the font, use the same font for adjacent controls to avoid alignment problems.   

  

 
 

To use an Equipment Color control 

When you add an Equipment Color control to a graphic, you link the oval to the equipment, choose the size of 
the oval, and select the Prime Variable in the Control Properties

1 Open i-Vu Open. 

 window in ViewBuilder. In i-Vu Open, the oval 
will display colors to indicate the status of the equipment (for example, ideal, warm, occupied, etc.). 

2 Right-click the controller in the navigation tree and select Copy Path from the drop down menu. 

3 Open ViewBuilder. Create a new view or open an existing one. 

NOTE  To place an Equipment Color control in your graphic, open the Add Control tab  in the 
Tools window. Click on the   and then click in the view to place it. 

4 Open the Control Properties window (Window>Show Control Properties).  

5 Paste (Ctrl+V) in the Equipment Path field. 

6 Select a large or small oval to appear on your graphic.  

NOTE  You must choose a large oval to display the Prime Variable. 

7 Optional: Check Show Prime Variable to display the prime variable in i-Vu Open. 
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8 Save your view. 

9 In i-Vu Open, right-click on the site or area in the navigation tree and select Configure from the drop-
down menu. 

10 Select your view and click Add. 

  

 
 

To add variable color to a text control 

For any control that displays alphanumeric characters, you can enter an expression that causes the text to 
change color in i-Vu Open based on the value of a microblock property. 

1 Select the control. 

2 Click  on the toolbar. 

3 Enter the expression. See Conditional expressions and examples below. 

NOTE  To add a color to your expression, click the color in the Color Insertion Tool box. A color’s 
hexadecimal value is inserted in the expression. 

4 Click OK. 

NOTE  To remove the conditional expression, delete the text in the Expression field. 

 

EXAMPLES: 

To... 

 

Enter the expression... 

Add a Text Toggle control that will 
determine a filter status and show the 
word Clean in green or Dirty in red 

(($filter/present_value$==true)?’#FF0000’:’#00FF00’) 

Add a Static Text control that displays red 
text to indicate an alarm or white text to 
indicate a normal condition 

(($alarm/present_value$==true)?’#FF0000’:’#FFFFFF’) 

  

 
 

To set a control to enable/disable 

You can enter a conditional expression that determines whether i-Vu Open enables or disables a control 
based on another control’s microblock property value. 

1 Select the control that you want to enable/disable. 

2 Click  on the toolbar. 

3 Enter the expression. See Conditional expressions and example below. 

4 Select the Enable or Disable when the expression is true option. 

5 Click OK. 

NOTE  To remove the conditional expression, delete the text in the Expression field. 

TIP  You can simultaneously set multiple controls to enable/disable using the same conditional expression. 

Each of the controls must have enable/disable capability. Select the controls, then click . 
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EXAMPLE: 

To... 

 

Enter the expression... 

Add an editable Number control after  Lock 
value at: 

$m006/locked$==true 
and select that will be enabled only when an 

operator clicks the checkbox 
Show when Expression is True 

  

to enable when 
true. 

 

Working with tables 

You can add a table to a graphic and then add controls or images in the table cells. The table maintains the 
alignment of the objects in the cells. 

 
  

 
 

To add a table 

1 Click the Add Control tab  in the Tools window. 

2 Select the Table control. 

3 Click in the workspace where you want to add the table. 

4 Do one of the following: 
Select Pre-Defined Table, then select the style you want to add. 
Select Custom Table, then enter the number of rows and columns. 

5 Click OK. 

  
 

To add a symbol to your graphic 

1 Click the Add Symbol tab  in the Tools window. 

2 In the Look in field, browse to the folder that contains the symbol you want. 

TIP  Click one of the five buttons at the left of the file list to jump to a location quickly. Hold the cursor 
over a button to see its destination. Click the last button to jump to the symbol library.  

3 Select the symbol and then click in the workspace where you want to add the symbol. 

TIP  You can also double-click a symbol's name in the Tools window to add it to the workspace. 

4 In the Control Properties window, edit properties as needed for the individual controls in the symbol. 

TIP  To add a symbol multiple times, select the symbol, then hold down Shift and click the workspace for 
each symbol. 
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NOTES 

• Symbols with extra objects  
Many symbols, such as the chiller shown below, include extra objects so you can create the configuration 
you need. Ungroup the symbol, then delete the unnecessary pieces. Reposition the remaining pieces if 
necessary. 

 
• Dampers  

If a single microblock controls two dampers and one should be the opposite of the other, use a regular 
symbol for one damper and a reversed symbol for the other. For example, use Horizontal_Open-Closed 
and Reversed_Horizontal_Open-Closed. 

  

 
 

To add text to a table 

1 Double-click a table cell. 

2 Type text. 

3 Optional:  Double-click the table icon at the top of the table to open the Table Editor, then align the text. 

  

 
 

To add a control to a table cell 

1 Click the control in the Tools window. 

2 Click the cell where you want to add the control. 

3 Enter the control’s properties. 

NOTE  You can add multiple objects to a table cell, then click and drag an object to rearrange them. 

TIP  To prevent a table from overlapping nearby objects as its content expands in i-Vu Open, set preview text 
or expected digits for each control in the table to be as wide as the widest value i-Vu Open might display. Then 
position your table. Or, set a minimum row height or a minimum column width for the table. 

  

 
 

Using the Table Editor 
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Use the Table Editor tools to: 

• Insert and delete columns and rows 

• Split and merge cells 

• Align cell contents 

• Align the entire table. A table can expand or shrink in i-Vu Open based on the values in its cells. You can 
align a table so that the left, right, or center of the table remains in a fixed position, regardless of the cell 
contents. 

• Set a table row to show or hide in i-Vu Open based on the value of a microblock property. See Setting 
objects to show/hide. 

• Change the background for one or more selected cells from transparent to a color. 

• Add a border to one or more selected cells. Set the border width between 1 and 10; 0 equals no border. 

• Set minimum column width and minimum row height. 

• Use column spacers to maintain a fixed amount of unused space between each column. To increase or 
decrease the amount of space, turn off the Table > Use Automatic Column Spacers option, add a 
column as a spacer, then set a minimum column width. 

  

 
 

Drawing lines and shapes 

ViewBuilder’s drawing tools let you draw vector lines and shapes. These tools are on the  tab in the 
Tools window. 

  

 
 

To define drawing attributes 

On the  tab, set the following Default Attributes that ViewBuilder will use for each new line or shape. 
After you draw the line or shape, you can change its attributes in the Control Properties window.  

Select any of the following checkboxes: 

• Line Thickness if drawing a line or giving a shape a border.  
Select the thickness and Line Color. 

• Background Fill Color to fill a shape with a color.  
Select the color. 

• Fill Pattern to fill a shape with a pattern.  
Select the pattern.  
The Background Fill Color is the pattern’s first color. Select a Fill Pattern Color as the second color. 
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To draw a line 

1 Select . 

2 Click in the workspace, but do not release the left mouse button. Drag the cursor to draw. 

NOTE  Hold down the Ctrl key as you draw to restrict the line to vertical or horizontal. 

3 Optional–To add a line segment:  While still holding the left mouse button, click and release the right 
mouse button, then drag in a new direction. 

4 Release the left mouse button to complete the drawing. 

5 If needed, change the line’s attributes (page 20) in the Control Properties window.  

  

 
 

To draw a polygon 

1 Select . 

2 Click in the workspace, but do not release the left mouse button. Drag the cursor to draw the first side of 
the polygon. 

3 While still holding the left mouse button, click and release the right mouse button, then drag in a new 
direction to draw the next side of the polygon.  

NOTE  Hold down the Ctrl key as you draw to restrict angles to right angles. 

4 Repeat step 3 as many times as needed. 

5 Release the left mouse button to complete the shape. 

6 If needed, change the shape’s attributes (page 20) in the Control Properties window. 

  

 
 

To draw a rectangle, square, ellipse, or circle 

1 Select  to draw a rectangle or square, or select  to draw an ellipse or circle. 

2 Click in the workspace, but do not release the left mouse button. Drag the cursor to draw. 

NOTE  Hold down the Ctrl key as you draw to form a square or circle.   

3 Release the left mouse button to complete the shape. 

4 If needed, change the shape’s attributes (page 20) in the Control Properties window. 

  

 
 

To resize or reshape a drawing 

1 Select the line or shape in the workspace. 

2 Click Edit Drawing button in the Control Properties window. The drawing’s points change from  to 

. 

3 Edit the line or shape. 
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○ To resize a rectangle, square, ellipse, or circle, click a corner point and drag it. 
NOTE  To maintain a circle or square, hold down Ctrl while dragging. 

○ To reshape a line or polygon: 

-  To move a point, click it and drag it. 

-  To delete a point, right-click it. 

-  To add a point, move the cursor on top of a line or border until the cursor changes to +, then right-
click. 

NOTE  You can press Esc to remove your edits. 

4 Left-click in the workspace to save edits.  

  

 
 

Adding links 

You can make images link to other pages in i-Vu Open or to the Internet. 

  

 
 

To add a link 

1 Select the object that is to be a link. 

NOTE You can select multiple objects if you want to link them to the same destination.  All of the selected 
objects must have linking capability.  

2 Click  on the toolbar. 

3 Enter the requested information. See table below. 

4 Click OK. 

NOTE  To remove the link from the control, delete the text in the Link field. 
 

Field Notes 

 General tab 

Enter the path to an item in the navigation tree, or enter a URL to link to an Internet web 
page. 

Link 

Select Scope 

• system to link to another page in i-Vu Open.  

• external to link to a URL address or an external document, such as a .pdf file. An 
external link will open in a separate window from i-Vu Open. 

Choose the action button to be selected when the operator clicks the link. Action Button 
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Enter the reference name for the Advanced tab Tab, Category, and Instance to be displayed when the i-
Vu Open operator clicks on the link. 
  

 
 

NOTE  To find the reference names, go to the location in i-Vu Open that you want to link 
to and use the whereami manual command. See “Manual Commands” in i-Vu Open 
Help. 

Type Navigation—links to an item in the navigation tree. 

Interactive-popup—opens a pop-up window such as a microblock pop-up. 

Select to have link underlined. Clear the checkbox to remove the underline. Underline Link 

  

 
 

Working with symbols 

Symbols are commonly used combinations of images, controls, and text that have been preconfigured and 
grouped. You can also create your own symbols. 

  

 
 

To create a symbol in ViewBuilder 

1 Click  on the toolbar. 

2 Add the objects to the workspace that you want to include in your symbol. 

3 Enter control properties, if needed. 

4 Select File > Save As. Save your symbol in a folder. 

5 Under Files of Type, select View Symbol files. 

6 Type the name of the symbol in the File Name field. 

7 Click Save. Use the Look in field on the Add Symbol tab to browse to your symbol. 

TIP  When adding a symbol you created, double-click the symbol in the Tools window to have it added at the 
same location it was in when you created it. 
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Setting objects to show/hide 

You can set images, most controls, and table rows to show or hide in i-Vu Open based on the value of a 
microblock property. 

  

 
 

To set an image or control to show/hide 

1 Select the image or control. 

2 Click  on the toolbar. 

3 Enter a conditional expression. See Conditional expressions and examples below. 

4 Select the Show or Hide when expression is true option. 

5 Click OK. 

NOTE  To remove the conditional expression, delete the text in the Expression field. 

 

EXAMPLES: 

To... 

 

Enter the expression... 

Add a Static Text control that shows "freezestat" 
when freezestat is in alarm 

$air_flow/full_open$==true 
and select 

Add a Toggle Button control that shows an alarm 
reset button (up and down image) only when an 
alarm occurs 

Show when Expression is True 

$alarm/present_value$==true 
and select 

TIPS 

Show when Expression is True 

• If you do not see an object when you test your graphic in i-Vu Open, look for the show/hide icon to the left 
of the object in ViewBuilder. This icon helps you quickly determine that the object is hidden, not missing. 

NOTE  ViewBuilder does not display the icon when you set an object inside a table cell to show/hide. 

• To simultaneously set multiple objects to show/hide using the same conditional expression, select the 

objects, then click .  

NOTE  Each of the objects must have show/hide capability. 

  

 
 

To set a table row to show/hide 

1 Open the Table Editor. See Working with tables. 

2 Click in the row. 

3 Select Row > Show/Hide. 

4 Enter a conditional expression. See Conditional expressions. 

5 Select the Show or Hide when expression is true option. 

6 Click OK. 

NOTE  To remove the conditional expression, delete the text in the Expression field. 
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To determine a microblock path to points 

In ViewBuilder, you enter paths in links, controls, and conditional expressions. A path tells i-Vu Open the route 
through the system hierarchy to an item in the system. For example, a path tells i-Vu Open where to find a 
value to display on a graphic or where to jump to when the operator clicks a link. You must assign a 
Microblock Path in the Control Properties window to associate the graphic element with the point.  

NOTES   

• If the graphic is associated with a single controller, the RefName is used as the path  

• If the point is to be displayed on a floorplan, or other graphical element that is not directly related to a 
controller, the geographic path is used 

To determine the microblock property path 
1 Open i-Vu Open. 

2 Click on the controller in the navigation tree.  

3 Select Properties page > Network Points tab to view the mapped points. 

4 Click on the desired point to open the dialog box and select the Summary tab. 

5 Drag your cursor across the path next to RefName (In the example, "damper_pos_ai" )and CTRL-C to 
copy the path to the Windows clipboard. 

 
 

6 Open ViewBuilder and click the point you are mapping. 

7 Click Window > Show Control Properties to open the Control Properties dialog box. 

8 Place your cursor in the Microblock Path field. 

9 CTRL-V to paste the path from your clipboard. 

 
 

Advanced topics 
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10 Verify that Property is present-value.  

11 Save your graphic. 

12 Upload to i-Vu Open.   

 

To determine the geographic path  
1 Open i-Vu Open. 

2 Click on the controller in the navigation tree.  

3 Select Properties page > BACnet Points tab to view the mapped points. 

4 Alt+Click on the Reference name of the point, or right-click and select Global Modify. 

5 Click the Show Advanced button. 

6 Click the Copy Path  button to copy the path to the Windows clipboard.  

 
7 Open ViewBuilder and click the point you are mapping. 

8 Click Window > Show Control Properties to open the Control Properties dialog box. 

9 Place your cursor in the Microblock Path field. 

10 CTRL-V to paste the path from your clipboard. 

11 Verify that Property is present-value.  

12 Save your graphic. 

13 Upload to i-Vu Open.   
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Miscellaneous ViewBuilder menu commands 

Menu command Notes 

Use this command if directed by Technical Support to install an added 
ViewBuilder feature. 

Tools > Configure 

Help > Use this command to install service packs or patches. Apply Update 

  

 
 

Conditional expressions 

You can type a conditional expression in ViewBuilder to show or hide an object, to enable or disable an object, 
or to display an object in variable colors based on a microblock property value. 

  

 
 

Show/hide or enable/disable expressions 

The following scenario shows how you could use an expression to show or hide a control on a graphic. 
Enable/disable works the same way. 

1 In ViewBuilder, you right-click a control, select Show/Hide, then type the following expression in the 
Show/Hide dialog box. 

Expression: 
Translation: 

$zone_temp/present_value$<70 
The present value of the zone temperature is less than 70. 

2 You select Show when Expression is True. 

3 When the graphic is displayed in i-Vu Open, the actual zone temperature is 75. Because the expression is 
false, i-Vu Open hides the control. 

 

Breakdown of the above expression 

 

A path to a microblock property  (enclosed in dollar signs)      Example:  $zone_temp/present_value$ 
The path can be relative, absolute, or global. See Defining i-Vu Open paths. 

NOTE  You can select the microblock in ViewBuilder's System window to display the path, which you can then 
copy and paste into your conditional expression. To use a relative path, right-click the area or piece of 
equipment whose graphic you are creating, then select Set Base Path. 
 

An operator      Example:  < 

A character that represents the relationship between the value of  the microblock property and  the 
literal value. See Operators 30 (page ) for a complete list of operators. 
 



Advanced topics  
 

28 ViewBuilder 5.1 
 

A literal value    Example:  70 
Either a number, as in the above example, or true or false, as in $zone_temp/locked$==true. 

 

  

 
 

Variable color expressions 

The following scenario shows how you could enter an expression to cause a text control to change color in i-
Vu Open based on the value of a microblock property. 

1 In ViewBuilder, you right-click a control that displays alphanumeric characters, select Variable Color, then 
type the following expression in the Variable Color dialog box. 
 

Expression: 
Translation: 

(($zone_temp/present_value$<70)?’#FF0000’:’#FFF660') 
If the statement "The zone temperature's present value is less than 70" is true, show 
red (#FF0000). If false, show yellow (#FFF660). 

2 When the graphic is displayed in i-Vu Open, the actual zone temperature is 75. Because the expression is 
false, i-Vu Open displays the control in yellow. 
 

Breakdown of the above expression 

 

A path to a microblock property  (enclosed in dollar signs)      Example:  $zone_temp/present_value$ 
The path can be relative, absolute, or global. See Defining i-Vu Open paths. 

NOTE  You can select the microblock in ViewBuilder's System window to display the path, which you can then 
copy and paste into your conditional expression. To use a relative path, right-click the area or piece of 
equipment whose graphic you are creating, then select Set Base Path. 
 

An operator      Example:  < 

A character that represents the relationship between the value of  the microblock property and  the 
literal value. See Operators 30 (page ) for a complete list of operators. 
 

A literal value    Example:  70 
Either a number, as in the above example, or true or false, as in $zone_temp/locked$==true. 
 

 A result 

NOTE  In a variable color expression, you enter a hexadecimal value for a color, such as #FF0000 for the color 
red. Color values must be enclosed in single quotation marks. For example, ’#FF0000’. 

   Example:  ?’#FF0000’:’#FFF660’ 
Variable color expressions include a color if the expression is true (#FF0000) and another color if the 
expression is false (#FFF660). The format of this part of the equation is ?’true color’:’false color’. 
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To find the hexadecimal value of a color 
1 Right-click on any text control and select Variable Color. 

2 Click Custom. 

3 Select the color you want. 

4 Click OK.  

5 Copy the hexadecimal value in the Expression field. 

  

 
 

Combining expressions 

Below are three methods, with examples, that you can use to combine expressions. 
 

Expression using  
the And operator: 

Method 1:  Use the And (&&) or the Or (||) operator 
$zone_temp/locked$==false 
&&$zone_temp/present_value$>75 
?#FF0000:#FFF660 

Translation: The zone temperature is not locked and the current value of the zone temperature is 
greater than 75. If both of these statements are true, show red (#FF0000); if either is 
false, show yellow (#FFF660). 

 

Expression: 

Method 2:  Use the Ternary (? :) operators 
$zone/M001/present_value$==1 
?’FF0000’:$zone/M001/present_value$==2 
?’#FFF660’:$zone/M001/present_value$==3 
?’#FFFFFF’:’#FF00FF’ 

Translation: The present value of M001 is 1.  If this is true, show red. If false, evaluate the next 
statement. The present value of M001 is 2. If this is true, show yellow. If false, 
evaluate the next statement. The present value of M001 is 3. If this is true, show 
white. If false, show magenta. 

 

Expression: 

Method 3:  Nest expressions 
$zone_temp/locked$==true 
?($zone_temp/locked_value$>75?#FF0000:#FFF660) 
:#00FF00 

Translation: The zone temperature is locked. If this statement is false, show green (#00FF00). 
If true, evaluate the nested statement that the locked value is greater than 75. If 
this statement is true, show red (#FF0000); if false, show yellow (#FFF660). 
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Operators 

An operator compares or performs an action between the value of a microblock property, a literal value, or 
the result of an expression. The following table lists operators that can be used in expressions.  

Operators that return true/false 

< Less than Compares numeric data. Returns true if the value to the left of the 
operator is smaller than the value to the right. 

> Greater than Compares numeric data. Returns true if the value to the left of the 
operator is larger than the value to the right. 

<= Less than or equal to Compares numeric data. Returns true if the value to the left of the 
operator is smaller than or equal to the value to the right. 

>= Greater than or equal to Compares numeric data. Returns true if the value to the left of the 
operator is larger than or equal to the value to the right. 

! Not Evaluates the expression and returns the opposite.  Example: 
!$zone_temp/locked$  
If zone_temp/locked is true, the expression is false. If 
zone_temp/locked is false, the expression is true. 

== Equal to Compares data. Returns true if the value on both sides of the 
operator are equal. 

!= Not equal to Compares data. Returns true if the value to the left of the operator 
does not match the value to the right. 

&& And Combines expressions. Returns true if the expressions on both 
sides of && result in true. 

|| Or Combines expressions. Returns true if the expression on either side 
or both sides of the operator results in true. 

Operators that return a numeric value 

+ Add Adds numeric data, expressions, or values. 

- Subtract Subtracts numeric data, expressions, or values. 

* Multiply Multiplies numeric data, expressions, or values. 

/ Divide Divides numeric data, expressions, or values. 

% Modulus Finds the remainder in the division of numeric data, expressions, or 
values. 

Other operators 

?  : Ternary The expression results in one of two values. If the left side of the 
question mark returns true, the value to the left of the colon is 
used. If the left side of the question mark returns false, the value to 
the right of the colon is used. 

( ) Parentheses Use to nest expressions. Operations in parentheses are evaluated 
before those outside parentheses. 
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Troubleshooting graphics 

Graphic errors are displayed when running i-Vu Open. The error may be indicated by a small red triangle  in 
the lower right corner of the i-Vu Open action pane. Click the triangle to see the error. 

Common errors and their solutions are listed below. 

  

 
 

Error:  Path is invalid 

 
Indicates that a path in the Link dialog box is invalid.  

Solution:  Correct the path. See To To determine a microblock path to points. 

  

 
 

Error:  Wrong data type 

 
Indicates that you used a non-binary control to read a binary value. For example, a number control to read a 
binary value. 

Solution:  Determine if you need to change the control or the microblock property value. 
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Error:  Cannot be evaluated 

 
Indicates the microblock path for a control is incorrect. 

Solution:  Correct the path. See To Determine a microblock path to points. 

  

 
 

Working with BACview screens 

A BACview is a combination keypad/display unit that you can attach to a controller to view or change its 
property values or its real-time clock without having to access the system's server. BACviews are available in 
the two sizes shown below.  

Virtual BACview is a software version of the large BACview shown below. The Virtual BACview runs on a laptop 
connected to a controller's Local Access port, and it has the same functionality as the BACview hardware. 

In ViewBuilder, you:  
• Create the screens that a BACview or the Virtual BACview will display 
• Test the navigation between screens 
• Save the screens in a single .bacview file 
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Follow the process below to create screens. 

1 Make a new BACview file or open an existing file. 

2 Make the BACview screens. 

3 Add text, controls, headers, and footers. 

4 Add navigation. 

5 Password-protect the screens. 

6 Set up alarms. 

7 Save, assign, and download the BACview file (page 47). 
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To make a new BACview file or open an existing file 

1 Do one of the following: 
  

To... 

Make a new BACview file 

Select... 

File > New

• 

, then select one of the following: 

BACview (4x40)

• 

 to make screens for a large BACview 

BACview (2x16)

Open an existing BACview file 
created in ViewBuilder  

 to make screens for a small BACview 

File > Open, then select the file. 

NOTE  If the file is not listed, verify that the Files of Type

  

 selection 
lists BACview files. 

1 Select File > Save As. 

2 Browse to a convenient location on your PC. 

3 Type a File Name, then click Save. ViewBuilder adds the .bacview extension to your filename. 
  

NOTES 

•  in the lower right corner of ViewBuilder indicates import errors or warnings. Click the triangle to see 
details. These details are available until you save the file. 

• To record information about the file, select Configure > View Properties, then type your name and 
comments on the Summary tab. Revision History shows each time the file was saved and the 
workstation it was saved on. 
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Getting to know ViewBuilder's BACview workspace 

When you make a BACview file in ViewBuilder, ViewBuilder displays a simulation of a BACview. You make your 
screens directly in the simulation's display, and you click the simulation's keys to test the navigation between 
screens. 
  

 
  

 
 

To move the cursor in a screen 
Use your keyboard's arrow keys to move the cursor in the screen. You can also use the following keys on your 
keyboard. 
  

Press... To jump to... 

The first cell of the line the cursor is in Home 

The last cell of the line the cursor is in End 

Ctrl+ The first cell of the screen's first line Home 

Ctrl+ The last cell of the screen's last line End 

  
NOTE  Hold down Shift while pressing the above keys to select everything from the cursor's current position to 
the new position. 
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To add lines to a screen 

1 Click the Screens tab  in the Tools window. 

2 In the Number Of Lines field, click  to add a line below the line the cursor is in.  
  

NOTES   

• Click  to delete the line the cursor is in. 

• To see all of a screen that exceeds the length of the BACview’s display, select Extended View. 

  

 
 

To select or move objects 
Objects in a screen are either text that you typed in the screen or controls that you added to the screen. See 
Adding text, controls, headers, and footers.  

You must select an object to perform any action on it.   
• Click a control to select it. 
• Click and drag across text to select it. 
• Click and drag across multiple objects in a screen to select the objects. 

  
To move a selected object, click and drag it to a new location in the screen. 

  

 
 

To copy an object 
Alt+click and drag a control or selected text to create a copy of it in the same screen. 
  

To copy a selected object(s) from one screen to another: 

1 Select the object(s), then click .  

2 In the new screen, click , then click in the screen where you want the object. 

  

 
 

To undo or redo actions 

Click  on the toolbar as many times as necessary to undo actions that you performed, beginning with the 
most recent action. Click  to redo the action. 

You can also click the drop-down arrow to the right of the Undo or Redo button to select an action from a list 
that begins with the most recent action. Selecting an action will undo or redo that action, plus all actions 
above it in the list. 
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Making BACview screens 

A .bacview file includes the default screens listed below and any screens that you create in ViewBuilder. 

  

 
 

Default screens 
[Every BACview file contains the screens listed below. The standby and home screens automatically display in 
the BACview, but you must provide navigation to a system screen to have it display. See Adding navigation. 
The home and standby screens are editable; system screens are not editable. 

NOTE  The Clockset and Comm screens contain links to other screens that are not listed in the Tools window 
in ViewBuilder because you do not edit them or provide navigation to them. These linked screens are also 
shown below. 
  
  

Screen 
name 

Description 

Displays when the BACview has had no operator activity for the time specified in the standby Keypad 
inactivity timeout field in the controller driver. Leave this screen blank or add controls or text to 
display information such as the date and time. Do not add lines to the standby screen. 

Displays when an operator presses a key while the BACview is in standby mode. home 
CAUTION

System screens 

  Because this is the first screen that you see when the BACview is activated, you must 
add navigation to other screens in the system.  

Displays if the screen the operator selected requires a password. LOGIN 

 
Lets the administrator set the user-level password. USERPW 

 
Displays alarms received by the controller. You must define the alarms in ViewBuilder to have 
them display. See Setting up alarms. 

ALARM 
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Lets an operator adjust the current time and date in the controller’s real time clock. CLOCKSET 

 
The [–>DST] link jumps to the following screen where an operator can adjust the beginning and 
ending dates for daylight savings time. 

 
(Large BACview only)—Lets an operator define: KEYPAD 

• The amount of time of inactivity before the standby screen is displayed 

NOTE

• The priority (1–16) the BACview uses to write to BACnet properties. 1 is the highest priority, 16 
is the default. 

  This time can also be defined in the controller driver. 

 
(Large BACview only)—Displays the controller's BACnet device name and ID. BACNET 

(Exec 6) 

 

 

COMM (Large BACview only)—Lets an operator set the protocol and communication parameters for the 
port that a third-party device is connected to.  
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If the operator sets 
the Protocol to... 

And 
Type 
to... 

BACnet 

  
  
The Protocol Setup link jumps to... 

485 

 
Modbus -- 

 
N2 -- 

 
NOTE

NOTE  System screens are a part of the BACview's firmware. If a screen in the firmware is changed between 
releases of ViewBuilder, the ViewBuilder screen may look different than the actual BACview screen. 

  BACnet MS/TP Setup is the only Protocol Setup screen that is visible in ViewBuilder. 

  

 
 

To add new screens 

1 Click the Screens tab  in the Tools window.  

2 Do one of the following: 

○ In the screen list, double-click "untitled", then type a descriptive name.  

○ Click  to add a new blank screen, then change its name. 

○ Select an existing screen, click  to make a copy of it, then change the copy's name. You cannot 
copy a system screen. 
  

NOTE  To delete a screen, select the screen name, then click .  You cannot delete any default screen. 

  

 
 

Adding text, controls, headers, and footers 

You can add text, controls, headers, and footers to a BACview screen. If needed, you can increase the size of 
a screen by adding up to 100 lines. 

CAUTION  Typing text or placing a control on top of an existing control deletes the existing control. 
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To add text 
Click in the cell where you want the text, then begin typing. 

You can also copy text from another application and then paste it into a BACview screen. 

To delete text, click and drag across the text to select it, then click  or press Delete. 

  

 
 

To add a BACview control 

1 Click the Add Control tab  in the Tools window. 

2 Select a control.  See BACview controls and their properties (page 40) for a description of each control. 

3 Click in the screen where you want the control. 

NOTE  If you select a control and then decide you do not want to add it to the screen, press Esc. 

4 Edit properties for the control in the Control Properties window. See BACview controls and their 
properties (page 40). 

5 Click in the screen or press Enter on your keyboard to apply the properties. 
  

NOTE  To copy a control or text: 
• Press Ctrl+c to copy the item and Ctrl+v
• Press 

 to paste it into the same screen or a different screen. 
Alt 

  
as you drag the item to a new location in the same screen. 

 
 

BACview controls and their properties 
Each control, its usage, and the properties you define are described in the table below. 

The first three controls have the following properties in common. 
  

Object Name Use ViewBuilder's System window to insert the Object Name (page 42) in this field. Or, 
you can find the point's Object Name in i-Vu Open on the point's Properties page > 
Details tab, under BACnet Configuration. 
NOTES 

• You must enable the point's Network Visible checkbox on the Details tab. 

• For a legacy .KPD file, use the point's display name. 

Editable Select to make the control editable in the BACview. 

  
  

Use this control... To... Properties 

 Number Display any numerical 
value from an analog 
microblock. 

Digits Left (or Right) of Decimal - Type the maximum 
number of digits that can appear to the left (or right) of 
the decimal. 

Show Degree Symbol - Select to display with a 
temperature. 

Range for Value - Type a Minimum and Maximum 
Value to define the acceptable range of values for the 
control. 
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Use this control... To... Properties 

 Multi-State 
Control 

Display the status of a 
microblock. 

Field Width - Select Use the length of the longest 
display value to have the full text from the Display 
column shown in the BACview, or select Use the 
following value

In the 

 and then type a number to have 
ViewBuilder truncate the displayed text to that number 
of characters. 

Value-Display table, edit the entries in the Value 
column to show the actual values that the microblock 

will produce. Click  to add a row to the table or  
to delete a row. For each value, change the Display 
column text to what you want that value to display in 
the BACview.  

NOTE  If this control is used in a large BACview, it is 
editable, and the operator has selected it, the softkeys 
give him the following options:  OK, CANCEL, 
DECR(EMENT), INCR(EMENT). 

 Advanced  
Multi-State 
Control 

(Large 
BACview only) 

Display the status of a 
microblock and assign 
point values to softkeys. 

 

Field Width - Select Use the length of the longest 
display value to have the full text from the Display 
column shown in the BACview, or select Use the 
following value

In the 

 and then type a number to have 
ViewBuilder truncate the displayed text to that number 
of characters. 

Value-Display-Softkey table, edit the entries in 
the Value column to show the actual values that the 

microblock will produce. Click  to add a row to the 

table or  to delete a row.  For each value, change 
the Display column text to what you want that value to 
display in the BACview.  

NOTE

If you make the control editable, you can assign values 
to softkeys that the BACview operator can use to edit 
the point's value. To do this, select a 

  The last value, NOP, gives the operator a means 
to cancel editing the control. You cannot delete this 
row. 

Softkey

Click 

 in the 
table for each value.  

 to add values to the table, or  to delete 
values. 

 Date Display the date in the 
controller's real time clock. 

Date Format - Choose how to display the date. 

 
Time Display the time in the 

controller's real time clock. 
Time Format - Choose how to display the time. 

 
Link Add a link to another 

screen. 
See To add a link to a screen 44 (page ). 

  
  
NOTE  If editing a control's property causes the control to overlap another control or to expand past the edge 
of the screen, the control appears in red to indicate the error. Drag the control to a new location. 
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EXAMPLE  In the figure below, the date format was changed from MM/YYYY to MM/DD/YYYY. 

 
  

 
 

To have ViewBuilder insert object names 
Use the System window to insert the Object Name in the Control Properties window.  

1 If you do not see the System window, click  on the toolbar. 

2 In the System window, select the system you want from the drop-down list. 

3 Click Next. 

4 In the Name field, select your user name from the drop-down list. 

5 Type your Password. 

6 Click Next. 

7 In the system tree, select the point for the control you want to program. 

8 Do one of the following: 

○ Right-click the Object Name field in the Control Properties window, then select Set Object Name. 

○ Select Edit > Set Object Name in ViewBuilder's menu. 

  

 
 

To add headers and footers 
A header is an area at the top of a screen that does not scroll; a footer is at the bottom.  

1 Click the Screens tab  in the Tools window. 

2 Set the number of rows for a header or footer in the Header or Footer field.  

EXAMPLE  Set the Header field to 1 to have the first row be a header; set the Footer field to 2 to have 
the last 2 rows of the screen be a footer.  

NOTE  The total number of lines you can use for a header and footer are 3 on large BACview and 1 on a 
small BACview. 

  

Setting items to show/hide 

You can set controls, text, or complete rows to show or hide based on one of the following: 

• The value of a microblock property 

• The password level of the user 
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EXAMPLE  You want to create a single control program and screen file that can be used in multiple 
applications. In the control program, you enable a microblock for one application, but disable it for another 
application. In the screen file, you set information that applies to that microblock to show when the 
microblock is enabled and hide when it is disabled. 

  

 
 

To set items to show/hide 

Based on a microblock property's value 
1 Select the item(s) you want to show/hide. 

2 Click  on the toolbar. 

3 In the Object Name field, type the microblock property's object name or select it from the drop-down list. 
You can use ViewBuilder's System window to find the object name (page 42). 

4 In the Show When field, select: 

○ True to show the information when the value of a binary microblock is 1 or the value of an analog 
microblock is anything other than 0.  

○ False to show the selection when the value is 0. 

5 Click OK.  
  

Based on the user's password level 
1 Select the item(s) you want to show/hide. 

2 Click  on the toolbar. 

3 In the Object Name field, select one of the following from the drop-down list: 

○ Sys.Exec.IsAdminLevel to show/hide the selected items to a user logged in with the Admin 
password 

○ Sys.Exec.IsUserLevel to show/hide the selected items to a user logged in with the User password 

NOTE  See Password-protecting a BACview screen for information on the Admin and User passwords. 

4 In the Show When field, select True. 

5 Click OK.  
  
  

NOTES   

• The cells that you assigned the show/hide condition to are highlighted by a color. A different color is used 
for each unique condition. 

• To move an item and its condition, hold down Ctrl as you drag the item.  

• To copy an item and its condition, hold down Alt as you drag the item. 

• Items moved or added into cells that have a show/high condition may or may not assume the condition. 
If you do not get the results you want, change the show/hide condition or click  to undo the action.  

• If you hide part of a row, the cells will be blank when the screen is viewed in a BACview.  If you hide an 
entire row, the row will be completely removed from the screen. Design your screen so that a large 
BACview will never have less than 4 rows and a small BACview will never have less than 2 rows. 
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To edit or remove a show/hide condition 
1 Select the cells whose condition you want to edit or remove. 

2 Click  on the toolbar. 

3 Do one of the following: 

○ To edit a condition, change the Object Name or Show When field. 

○ To remove a condition, delete the text in the Object Name field. 

4 In the Apply To field, select: 

○ Selections only to have the changes apply only to the selected cells. 

○ Wherever Used to have the changes apply everywhere that the condition is used. 

5 Click OK. 

  
 

Adding navigation to the screens 

You can give an operator the following methods of moving from one screen to another: 
  

When you provide a... The operator... 

Link Uses the arrow keys to select the link, then presses Enter 

Softkey link 
(Large BACview only) 

to go to the 
linked screen 

Presses the softkey below the link 

Hotkey 
(Large BACview only) 

Presses FN 

  

plus the number key assigned to a particular screen 

 
 

To add a link 
If you place a link on a screen, the operator can use the arrow keys to select the link, and then press Enter to 
go to the linked screen. 

To add a link: 

1 Click the Add Control tab  in the Tools window. 

2 Select Link. 

3 Click in the screen where you want the link.  

4 In the Control Properties window, do one of the following: 
  

If you want the link 
to go to... 

A specific screen 

  
Then... 

In the Link to Screen

The previous screen 

 field, select the screen the link will jump to. 

Select the Previous Screen 

  

checkbox. 
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5 In the Link text field, type the text that you want your screen to show for the link. 

NOTE  This field is not editable if you link to a system screen. 

  

 
 

To add a softkey link 
If you assign a softkey number to the link directly above the softkey, the operator can press that softkey to 
jump to the linked screen. 

To add a softkey link: 

1 Click the Add Control tab  in the Tools window. 

2 Select Link. 

3 Click in the screen directly above the softkey that you want to be the link. See figure below. 

4 In the Control Properties window, do one of the following: 
  

If you want the link 
to go to... 

A specific screen 

  
Then... 

In the Link to Screen

The previous screen 

 field, select the screen the link will jump to. 

Select the Previous Screen 

  

checkbox. 

5 In the Link text field, type the text that you want your screen to show for the link. 

NOTE  This field is not editable if you link to a system screen. 

6 Select the softkey number in the Assign to Softkey field. 
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To assign a hotkey to a screen 
If you assign a hotkey number to a screen, an operator can press FN plus that number to jump to the screen. 
  

If you want a  
hotkey to go to... 

  
Then... 

A specific screen 
1 Click the Screens tab  in the Tools 

2 Select the screen name. 

window. 

3 Select the hotkey number in the Hotkey 

The previous screen 

field. 

Select a hotkey number in the Previous Screen Hotkey

  
TIP  Create a screen that shows all the hotkeys and their destinations. 

 field.  

  

 
 

To test the navigation 
 

To test a... Click anywhere outside the BACview screen and then click... 

Link The arrow keys to select the link (the link will have brackets around it). Then click 
Enter

Softkey link 
(Large BACview only) 

. 

The softkey below the link. 

Hotkey link 
(Large BACview only) 

FN

  

 and then the hotkey number assigned to a screen. 

 
 

Password-protecting a BACview screen 

To provide security for your i-Vu Open system, you can assign a password level to a screen on the Screens tab 

 in the Tools window.  
  

A screen with this 
password level... 

  
Can be accessed by... 

Anyone, but to edit a field in this screen, the operator must log in with 
either the User or Admin password. 

None 

An operator logged in with the User or Admin password. User 

An operator logged in with the Admin password. Admin 

  
Create the 4-digit Admin and User passwords using the instructions below. 
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To create the Admin password 
1 In ViewBuilder's menu, select Configure > View Properties. 

2 Type any 4-digit number in the Admin Password field.  

  
 

To create the User password 
The BACview has a single User password shared by its operators. You do not create this password in 
ViewBuilder. The person with the Admin password creates the User password on the BACview after the 
.bacview file has been downloaded to the controller.  

To create the User password: 

1 Navigate to the USERPW screen on the BACview. 

2 Log in with the Admin password. 

3 Type any 4-digit number as the User password. 

  
 

Setting up alarms for a BACview 

The BACview Alarm LED turns on (and the BACview horn may sound) when its controller receives a BACnet 
alarm that you set up on the Alarms tab in the Tools window. An operator can view the alarm description on 
the ALARM screen. 
  

To set up an alarm: 

1 Click the Alarms tab  in the Tools window. 

2 Click the  to add an alarm. 

3 Double-click that alarm's Alarm Name cell, then change the existing text to the alarm's BACnet Object 
Name. 

4 Double-click the alarm's Description cell, then change the existing text to the description that you want to 
appear on the ALARM screen. 

5 Select the Use Horn? checkbox to have the BACview audibly notify an operator when it receives an alarm. 
  

NOTES   

• To delete an alarm, select the alarm, then click . 

• Click a column heading on the Alarms tab to sort the alarms. 

• You should enable each alarm's Return to Normal field in i-Vu Open to prevent the Alarm LED and horn 
from remaining on until an operator can clear the alarm.   

  

To save, assign, and download the BACview file 

1 Save the .bacview file in i-Vu Open#\webroot\<system_name>\views\bacviews. 

2 In i-Vu Open, download the control program into the controller. See "Downloading system changes to 
controllers" in i-Vu Open Help. 
  

NOTE  If the controller has an Enhanced Access Port DIP switch, make sure that this DIP switch is off when 
connecting a BACview. 
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